<!doctype html>
<html lang=en>
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><meta name=viewport content="width=device-width,initial-scale=1"><title>The Church must do better at preparing couples for marriage</title><link rel=canonical href=https://rumble.com/vdbmxl-the-church-must-do-better-at-preparing-couples-for-marriage.html><link rel=dns-prefetch href=https://connect.facebook.net><link rel=dns-prefetch href=https://www.facebook.com><link rel=dns-prefetch href=https://imasdk.googleapis.com><link rel=preconnect href=https://www.google-analytics.com><link rel=preconnect href=https://i.rmbl.ws><style>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</style><script>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</script><script type=application/ld+json>[{"@context":"http://schema.org","@type":"VideoObject","name":"The Church must do better at preparing couples for marriage","playerType":"HTML5","description":"Bishop Strickland says clergy should teach more on forming 'moral consciences,' especially as it pertains to family and marriage. To help LifeSite continue sharing videos on important and vital topics","thumbnailUrl":"https://i.rmbl.ws/s8/1/z/x/x/v/zxxvb.qR4e-small-The-Church-must-do-better-a.jpg","uploadDate":"2021-01-27T19:09:04+00:00","duration":"PT00H25M29S","embedUrl":"https://rumble.com/embed/vapgqx/","url":"https://rumble.com/vdbmxl-the-church-must-do-better-at-preparing-couples-for-marriage.html","width":1280,"height":720,"videoQuality":"Full HD"},{"@context":"http://schema.org","@type":"WebSite","url":"https://rumble.com/","potentialAction":{"@type":"SearchAction","target":"https://rumble.com/search/video?q={search}","query-input":"required name=search"}},{"@context":"http://schema.org","@type":"Organization","name":"Rumble","url":"https://rumble.com/","logo":"https://rumble.com/i/rumble_logo_back.png","sameAs":["https://www.facebook.com/rumblevideo/","https://twitter.com/rumblevideo"]}]</script><meta name=description content="Bishop Strickland says clergy should teach more on forming 'moral consciences,' especially as it pertains to family and marriage. To help LifeSite continue sharing videos on important and vital topics"><meta property=og:site_name content=Rumble><meta property=og:type content=video.other><meta property=og:title content="The Church must do better at preparing couples for marriage"><meta property=og:url content=https://rumble.com/vdbmxl-the-church-must-do-better-at-preparing-couples-for-marriage.html><meta property=og:description content="Bishop Strickland says clergy should teach more on forming 'moral consciences,' especially as it pertains to family and marriage. To help LifeSite continue sharing videos on important and vital topics"><meta property=og:image content=https://i.rmbl.ws/s8/1/z/x/x/v/zxxvb.qR4e-small-The-Church-must-do-better-a.jpg><meta name=twitter:card content=summary_large_image><meta name=twitter:image content=https://i.rmbl.ws/s8/1/z/x/x/v/zxxvb.qR4e-small-The-Church-must-do-better-a.jpg><meta name=twitter:title content="The Church must do better at preparing couples for marriage"><meta name=twitter:description content="Bishop Strickland says clergy should teach more on forming 'moral consciences,' especially as it pertains to family and marriage. To help LifeSite continue sharing videos on important and vital topics"><meta name=robots content=noindex><meta property=fb:app_id content=155223717937973><meta name=twitter:site content=@rumblevideo><link rel="shortcut icon" href=/i/favicon.png><link rel=apple-touch-icon href=/i/favicon.png><link rel="manifest" href="/manifest.json"></head>		<body>
				<main>
			<div class="constrained">
				<article><h1 class="h1">The Church must do better at preparing couples for marriage</h1><div class="media-under-title">		<div class="media-by">
			<div class="media-by-wrap">
				<a class="media-by--a" href="/user/LifeSiteNews" rel=author>
					<i class='user-image user-image--img user-image--img--id-47a10c4f34831c9ec896ec7ea0edc2e6 media-user-image'></i>					<span class="media-heading-name">LifeSiteNews									</span>
				</a>
				<span class="media-heading-info media-heading-published"><span class="media-heading-title">Published </span> January 27, 2021</span>
											</div>
		</div>
				<div class="media-engage">
					<button data-title=LifeSiteNews data-slug="LifeSiteNews" data-type="user" data-action="subscribe" class="round-button media-subscribe bg-green">
			<span class="subscribe-button-label">Subscribe</span>
					</button>
					<button class="round-button media-engage-share desktop-only bg-blue">Share<svg class=media-icon-share width=18 height=18 viewBox="0 0 24 24"><path d="M18.7 16c-1 0-2 .5-2.7 1.2l-5-3.1c0-.4.1-.7.1-1.1 0-.4-.1-.7-.2-1.1l5-3.1c.8.7 1.7 1.2 2.8 1.2 2.1 0 3.8-1.8 3.8-4s-1.7-4-3.8-4c-2.1 0-3.8 1.8-3.8 4 0 .4.1.7.2 1.1L10 10.2C9.3 9.5 8.3 9 7.3 9c-2.1 0-3.8 1.8-3.8 4s1.7 4 3.8 4c1 0 2-.5 2.7-1.2l5 3.1c0 .4-.1.7-.1 1.1 0 2.2 1.7 4 3.8 4 2.1 0 3.8-1.8 3.8-4s-1.7-4-3.8-4zm0-12c1 0 1.9.9 1.9 2s-.9 2-1.9 2c-1 0-1.9-.9-1.9-2s.9-2 1.9-2zM7.3 15c-1 0-1.9-.9-1.9-2s.9-2 1.9-2c1 0 1.9.9 1.9 2s-.9 2-1.9 2zm11.4 7c-1 0-1.9-.9-1.9-2 0-.4.1-.7.3-1 .3-.6 1-1 1.6-1 1 0 1.9.9 1.9 2s-.9 2-1.9 2z" /></svg></button>
		</div>
		</div>		<div class="media-content">
			<div class="video-player" id="videoPlayer" style="z-index:0;position:relative"></div><div class="video-footer-buttons">		<div class="rumbles-vote" data-type="1" data-id="17984265">
			<button data-vote="1" class="rumbles-vote-up" aria-label="Rumbles up vote"><svg class=icon-rumbles-up width=16 height=16><path stroke-width="3" d="M1.5 8l13 0m-6.5-6.5l0 13" /></svg></button>
			<button data-vote="-1" class="rumbles-vote-down" aria-label="Rumbles down vote"><svg class=icon-rumbles-down width=16 height=16 viewBox="0 0 16 16"><path stroke-width="3" d="M1.5 8l13 0" /></svg></button>
			<span class="rumbles-count">3</span>&nbsp;<span class="rumbles-unit">rumbles</span>
		</div>
				<div style="display: flex">
				<button class="round-button media-video-action media-video-action-embed">Embed<svg class=media-icon-embed width=20 height=20 viewBox="0 0 20 20"><path fill="none" d="M16.2 7h-2c-6 0-10.9 4.6-10.9 10.3m9.1-6.3l4-4-4-3.9"/></svg></button>
						<button class="round-button media-engage-share mobile-only bg-blue">Share<svg class=media-icon-share width=18 height=18 viewBox="0 0 24 24"><path d="M18.7 16c-1 0-2 .5-2.7 1.2l-5-3.1c0-.4.1-.7.1-1.1 0-.4-.1-.7-.2-1.1l5-3.1c.8.7 1.7 1.2 2.8 1.2 2.1 0 3.8-1.8 3.8-4s-1.7-4-3.8-4c-2.1 0-3.8 1.8-3.8 4 0 .4.1.7.2 1.1L10 10.2C9.3 9.5 8.3 9 7.3 9c-2.1 0-3.8 1.8-3.8 4s1.7 4 3.8 4c1 0 2-.5 2.7-1.2l5 3.1c0 .4-.1.7-.1 1.1 0 2.2 1.7 4 3.8 4 2.1 0 3.8-1.8 3.8-4s-1.7-4-3.8-4zm0-12c1 0 1.9.9 1.9 2s-.9 2-1.9 2c-1 0-1.9-.9-1.9-2s.9-2 1.9-2zM7.3 15c-1 0-1.9-.9-1.9-2s.9-2 1.9-2c1 0 1.9.9 1.9 2s-.9 2-1.9 2zm11.4 7c-1 0-1.9-.9-1.9-2 0-.4.1-.7.3-1 .3-.6 1-1 1.6-1 1 0 1.9.9 1.9 2s-.9 2-1.9 2z" /></svg></button>
					</div>
		</div><div class="container content media-description"><p class="media-description">			<span class="breadcrumbs">
			<span property="itemListElement" typeof="ListItem">
				<a href="/" property="item" typeof="WebPage">Rumble</a>
			</span> — </span>Bishop Strickland says clergy should teach more on forming &apos;moral consciences,&apos; especially as it pertains to family and marriage.</p>
<p class="media-description">To help LifeSite continue sharing videos on important and vital topics, consider donating here: <a href="https://give.lifesitenews.com/?utm_source=StricklandMarriage" rel=nofollow target=_blank>https://give.lifesitenews.com/?utm_source=StricklandMarriage</a></p>
<p class="media-description">Sign-up for LifeSite&apos;s video newsletter here: <a href="https://bit.ly/LifeSiteVideoSub" rel=nofollow target=_blank>https://bit.ly/LifeSiteVideoSub</a></p>
<p class="media-description">Sign-up for LifeSite&apos;s email newsletter so you’ll never miss a beat: <a href="https://www.lifesitenews.com/ajax/subscribe?utm_source=StricklandMarriage" rel=nofollow target=_blank>https://www.lifesitenews.com/ajax/subscribe?utm_source=StricklandMarriage</a></p>
<p class="media-description">Follow LifeSite on social media<br>Telegram: <a href="https://t.me/lifesitetelegram" rel=nofollow target=_blank>https://t.me/lifesitetelegram</a><br>Gab: <a href="https://gab.com/LifeSiteNews" rel=nofollow target=_blank>https://gab.com/LifeSiteNews</a><br>MeWe: <a href="https://mewe.com/i/lifesitenewscom1" rel=nofollow target=_blank>https://mewe.com/i/lifesitenewscom1</a><br>Rumble: <a href="https://rumble.com/user/LifeSiteNews" rel=nofollow target=_blank>https://rumble.com/user/LifeSiteNews</a><br>Parler: <a href="https://parler.com/profile/LifeSiteNews" rel=nofollow target=_blank>https://parler.com/profile/LifeSiteNews</a><br>Facebook: <a href="https://www.facebook.com/LifeSiteNews" rel=nofollow target=_blank>https://www.facebook.com/LifeSiteNews</a><br>Twitter: <a href="https://twitter.com/LifeSite" rel=nofollow target=_blank>https://twitter.com/LifeSite</a></p>
</div>			<button
				id="login-to-see-comments"
				class="round-button bg-green"
				style="text-align:center; margin: 2em auto 1em auto; min-width: 50%; display: block"
			>
									Sign in and be the first to comment
							</button>
			<div style="text-align: center; font-size: 1.2rem; margin-bottom: 2em">... and disable advertisements! No kidding :)</div>
					</div>
		<aside class="media-sidebar">
			<ul class="mediaList-list container content related without-show-more-link"><li class="mediaList-item first-item">	<a class="mediaList-link size-medium" href="/vcp9ld-liberty-bible-church-advice-on-singlness-and-marriage-1-corinthians-71-9.html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/6/r/J/y/r/rJyrb.0kob.1.jpg" alt="Liberty Bible Church / Advice on Singlness and Marriage / 1 Corinthians 7:1-9">
							<small class="mediaList-duration">1h01m29s</small>
					</div>
		<div class="mediaList-info first-item">
			<h3 class="mediaList-heading size-medium">Liberty Bible Church / Advice on Singlness and Marriage / 1 Corinthians 7:1-9</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--img user-image--img--id-d60b04bc612bc241e985adbc9a634536 mediaList-by-image'></i>				<div>
					<h4 class="mediaList-by-heading">Liberty Bible Church</h4>
																								</div>
			</section>
		</div>
		</a></li><li class="mediaList-item">	<a class="mediaList-link size-medium" href="/v8xflj-church-preparing-for-coronavirus.html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/1/3/u/n/5/3un5a.0kob-small-Church-Preparing-For-Corona.jpg" alt="Church Preparing For Coronavirus">
							<small class="mediaList-duration">2m44s</small>
					</div>
		<div class="mediaList-info">
			<h3 class="mediaList-heading size-medium">Church Preparing For Coronavirus</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--letter mediaList-by-image' data-letter=K></i>				<div>
					<h4 class="mediaList-by-heading">KJRH</h4>
																								</div>
			</section>
		</div>
		</a></li><li class="mediaList-item">	<a class="mediaList-link size-medium" href="/vbrq3n-the-church-must-know.html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/6/J/F/A/l/JFAlb.0kob.1.jpg" alt="The Church Must Know">
							<small class="mediaList-duration">1h08m52s</small>
					</div>
		<div class="mediaList-info">
			<h3 class="mediaList-heading size-medium">The Church Must Know</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--letter mediaList-by-image' data-letter=s></i>				<div>
					<h4 class="mediaList-by-heading">stokesrg</h4>
																								</div>
			</section>
		</div>
		</a></li><li class="mediaList-item">	<a class="mediaList-link size-medium" href="/vc6esf-the-church-must-rise-up.html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/6/F/X/b/o/FXbob.0kob.1.jpg" alt='"THE CHURCH MUST RISE UP"'>
							<small class="mediaList-duration">21m54s</small>
					</div>
		<div class="mediaList-info">
			<h3 class="mediaList-heading size-medium">"THE CHURCH MUST RISE UP"</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--img user-image--img--id-91b7db405102d9ec8dd08674727e9a1e mediaList-by-image'></i>				<div>
					<h4 class="mediaList-by-heading">Founder James M Murphy</h4>
																								</div>
			</section>
		</div>
		</a></li><li class="mediaList-item">	<a class="mediaList-link size-medium" href="/vbsyll-ecclesia-why-the-church-must-gather.html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/6/P/K/O/l/PKOlb.0kob.1.jpg" alt="ECCLESIA -Why The Church MUST gather">
							<small class="mediaList-duration">20m07s</small>
					</div>
		<div class="mediaList-info">
			<h3 class="mediaList-heading size-medium">ECCLESIA -Why The Church MUST gather</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--img user-image--img--id-f254ca0dbfbc5b5e885044cc062ec874 mediaList-by-image'></i>				<div>
					<h4 class="mediaList-by-heading">Total Change with Terry Somerville</h4>
																								</div>
			</section>
		</div>
		</a></li><li class="mediaList-item">	<a class="mediaList-link size-medium" href="/vcr5y7-pastor-jackson-lahmeyer-why-the-church-must-physically-meet.html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/1/F/l/U/r/FlUrb.0kob-small-Pastor-Jackson-Lahmeyer-Why.jpg" alt="Pastor Jackson Lahmeyer | Why the Church Must Physically Meet">
							<small class="mediaList-duration">1h05m40s</small>
					</div>
		<div class="mediaList-info">
			<h3 class="mediaList-heading size-medium">Pastor Jackson Lahmeyer | Why the Church Must Physically Meet</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--img user-image--img--id-46bea577f707d228a62dd9a1d810ff68 mediaList-by-image'></i>				<div>
					<h4 class="mediaList-by-heading">thrivetimeshow</h4>
																								</div>
			</section>
		</div>
		</a></li><li class="mediaList-item">	<a class="mediaList-link size-medium" href="/vbvs1v-better-do-nothing..html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/6/d/R/i/m/dRimb.0kob.1.jpg" alt="better do nothing.">
							<small class="mediaList-duration">45s</small>
					</div>
		<div class="mediaList-info">
			<h3 class="mediaList-heading size-medium">better do nothing.</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--img user-image--img--id-5f04d57394061b9f017b09f951cad1df mediaList-by-image'></i>				<div>
					<h4 class="mediaList-by-heading">Life&#39;Fx</h4>
																								</div>
			</section>
		</div>
		</a></li><li class="mediaList-item">	<a class="mediaList-link size-medium" href="/vd2o8x-better-fitness.html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/1/b/r/X/t/brXtb.0kob-small-Better-Fitness.jpg" alt="Better Fitness">
							<small class="mediaList-duration">51s</small>
					</div>
		<div class="mediaList-info">
			<h3 class="mediaList-heading size-medium">Better Fitness</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--img user-image--img--id-52f92221b198468256ab4446f48fb453 mediaList-by-image'></i>				<div>
					<h4 class="mediaList-by-heading">WXYZ</h4>
																								</div>
			</section>
		</div>
		</a></li><li class="mediaList-item">	<a class="mediaList-link size-medium" href="/vcl03b-hanger-church.html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/1/3/-/N/q/3-Nqb.0kob-small-Hanger-Church.jpg" alt="Hanger Church">
							<small class="mediaList-duration">5m48s</small>
					</div>
		<div class="mediaList-info">
			<h3 class="mediaList-heading size-medium">Hanger Church</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--img user-image--img--id-4979801fe3a8ac9eaad111dbccfe8345 mediaList-by-image'></i>				<div>
					<h4 class="mediaList-by-heading">My Hanger Art</h4>
																								</div>
			</section>
		</div>
		</a></li><li class="mediaList-item last-item">	<a class="mediaList-link size-medium" href="/vcjlj8-better-food.html">
				<div class="mediaList-image-div size-medium">
				<img class="mediaList-image" src="https://i.rmbl.ws/s8/6/e/_/x/q/e_xqb.0kob.1.jpg" alt="BETTER FOOD">
							<small class="mediaList-duration">13s</small>
					</div>
		<div class="mediaList-info last-item">
			<h3 class="mediaList-heading size-medium">BETTER FOOD</h3>
			<section class="mediaList-by size-medium"><i class='user-image user-image--letter mediaList-by-image' data-letter=L></i>				<div>
					<h4 class="mediaList-by-heading">Lamonda</h4>
																								</div>
			</section>
		</div>
		</a></li></ul>		</aside>
		<div style="height:20px;clear:both"></div>
		</article>			</div>
		</main>
				<header class="header">
			<div class="header-div constrained">
				<button class="main-menu-toggle" aria-label="main menu">
					<svg class=main-menu-open width=20 height=16><path d="M0 1h20M0 8h20M0 15h20" /></svg>					<svg class=main-menu-close width=20 height=16><path d="M2.5.5 l15 15 m0-15 l-15 15" /></svg>				</button>
				<a href="/" class="header-logo"><img src="/img/rumble.svg" alt="Rumble"></a>
						<form class="header-search">
						<select class="header-search-select">
									<option>Videos</option>
									<option>Channels</option>
							</select>
			<input type=search class="header-search-field" name="query" placeholder="Search" value="">
			<button class="header-search-submit" aria-label="search Rumble">
				<svg class=header-search-icon viewBox="0 0 26 26"><path fill="none" stroke-linecap="round" stroke-width="2" d="M17.6 17.6l6.3 6.3M2.2 11.2a9 9 0 1 0 18 0 9 9 0 1 0-18 0"/></svg>			</button>
		</form>
						<button class="header-upload" title=Upload aria-label=Upload>
					<svg viewBox="0 0 26 26"><path fill="none" stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M4.2 17.5s-2.7-3.1-1.9-7.1C3 6.8 5.9 3.9 9.9 3.9c3.5 0 5.1 1.6 6.2 2.7 1.1 1.1 1.4 3.5 1.4 3.5s2.7-.7 4.4.7 2.4 3.8 1.8 5.6-2.6 3.1-2.6 3.1M9 17.1l4.1-3.8 4.2 3.8m-4.2 5.4v-9.2"/></svg>				</button>
						<button class="header-user" aria-label="sign in">
			<svg class="user-image user-image--icon header-user-img"><path fill="none" stroke-linecap="round" stroke-width="2" d="M8 6.8a5 5 0 1 0 10 0 5 5 0 1 0-10 0m14.8 16.7v-3.7a4 4 0 0 0-4-4H7.2a4 4 0 0 0-4 4v3.7"/></svg>				<span class="header-user-info">
					<span class="header-user-name">Sign In</span>
					<span class="header-user-stat">0 Rumbles</span>
				</span>
					</button>
					</div>
		</header>
				<nav class="navs">
			<div class="constrained" style="position:relative">
				<div id="main-menu" class="hover-menu main-menu-nav">
					<a class="main-menu-item" href="/videos"><svg class=main-menu-icon><path fill="none" d="M5 13a8 8 0 1 0 16 0 8 8 0 1 0-16 0M2.9 8.6C4.1 6 6.2 3.9 8.7 2.8m14.5 14.7a11.5 11.5 0 0 1-5.8 5.7M13 6.9V13h4.2"/></svg>Latest</a>		<a class="main-menu-item" href="/editor-picks"><svg class=main-menu-icon width=26 height=27 viewBox="0 0 26 27"><path fill="none" d="M4 8a6.5 7 0 1 0 13 0A6.5 7 0 1 0 4 8m15 13.5C15.6 11 1.1 13.9 1 25m13-2.4l3.9 4.4 7.1-8"/></svg>Editor Picks</a>
		<a class="main-menu-item" href="/videos?sort=views&date=this-week"><svg class=main-menu-icon width=25 height=34 viewBox="0 0 25 26"><path fill="none" d="M0 19c10-.6 18.1-9 16.9-18M11 7l5.9-6L23 7"/></svg>Trending</a>
				<a class="main-menu-item" href="/license-videos"><svg class=main-menu-icon width=26 height=26 viewBox="0 0 26 26"><path fill="none" d="M19.1 20H2.3V6h11.8M24.3 20h-5.5s-.9-1.5-1.4-2c-.5-.5-1-1.3-1.9-1.7-.4-.2-2.2-1.6-2.3-2.5 0-1.7 1.1-1.4 2.3-1 1.2.5 3.6 1.6 3.6 1.6l-.9-6.7S12.9 6.2 13 5.9c.1-.3 5.8-1.9 7.2-.2s2 4.5 2.8 5.1c.8.6 1.5.6 1.5.6 M6.8,11.1a1.8,1.8 0 1,0 3.6,0a1.8,1.8 0 1,0 -3.6,0 M5.8 16.6c0-1.5 1.2-2.7 2.7-2.7s2.7 1.2 2.7 2.7"/></svg>License Videos</a>
				<h3 class="main-menu-heading">Featured Channels</h3><a class="main-menu-item" href="/user/vivafrei">vivafrei</a><a class="main-menu-item" href="/user/afv">AFV</a><a class="main-menu-item" href="/user/ViralHog">Viral Hog</a><a class="main-menu-item" href="/c/PragerU">PragerU</a><a class="main-menu-item" href="/c/c-329697">InfinitiCraftingCo</a><a class="main-menu-item" href="/c/AmericanThoughtLeaders">AmericanThoughtLeaders</a><a class="main-menu-item" href="/c/SeanHannity">SeanHannity</a><a class="main-menu-item" href="/c/HodgeTwins">HodgeTwins</a><a class="main-menu-item" href="/c/SamuelEarpArtist">SamuelEarpArtist</a><a class="main-menu-item" href="/c/c-347045">TheNerdRealm</a><a class="main-menu-item" href="/c/DailyCaller">DailyCaller</a><a class="main-menu-item" href="/c/NewsmaxTV">NewsmaxTV</a><a class="main-menu-item" href="/c/sideserfcakes">sideserfcakes</a><a class="main-menu-item" href="/c/c-353475">spaceXcentric</a><a class="main-menu-item" href="/c/c-372955">JoeySalads</a><a class="main-menu-item" href="/c/c-374625">ACLJ</a><a class="main-menu-item" href="/c/OutKickTheCoverage">OutKickTheCoverage</a><a class="main-menu-item" href="/c/MarkLevinShow">MarkLevinShow</a><a class="main-menu-item" href="/c/GlennBeck">GlennBeck</a><a class="main-menu-item" href="/c/c-438015">TheHistoryGuy</a><a class="main-menu-item" href="/c/c-472747">Dershow</a><a class="main-menu-item" href="/c/COPSTV">COPSTV</a><a class="main-menu-item" href="/c/WochitBusiness">WochitBusiness</a><a class="main-menu-item" href="/c/c-3614">Wild Creatures</a><a class="main-menu-item" href="/c/WXYZ">WXYZ</a><a class="main-menu-item" href="/c/KERO">KERO</a><a class="main-menu-item" href="/c/KTNV">KTNV</a><a class="main-menu-item" href="/c/BarcroftCars">BarcroftCars</a><a class="main-menu-item" href="/c/NarcityCanada">NarcityCanada</a><a class="main-menu-item" href="/c/Newsy">Newsy</a><a class="main-menu-item" href="/c/ScienceMagazine">ScienceMagazine</a><a class="main-menu-item" href="/c/WochitNews">WochitNews</a><a class="main-menu-item" href="/c/WochitEntertainment">Wochit Entertainment</a><a class="main-menu-item" href="/c/Reuters">Reuters</a><a class="main-menu-item" href="/c/WochitTech">Wochit Tech</a><a class="main-menu-item" href="/c/DigitalTrends">Digital Trends</a><a class="main-menu-item" href="/c/c-201411">The Fumble</a><a class="main-menu-item" href="/c/iONE_HollyScoop">HollyScoop</a><a class="main-menu-item" href="/c/DevinNunesPodcast">Devin Nunes Podcast</a><a class="main-menu-item" href="/c/Bongino">The Dan Bongino Show</a><a class="main-menu-item" href="/c/DiamondandSilk">Diamond & Silk</a><a class="main-menu-item" href="/c/DineshDsouza">Dinesh Dsouza</a><a class="main-menu-item" href="/c/OANN">OANN</a><a class="main-menu-item" href="/c/CharlieKirk">CharlieKirk</a>				</div>
							</div>
		</nav>
				<footer class="footer">
			<div class="constrained">
				<nav class="footer-nav">
					<a class="footer-nav-link" target=_blank rel=noopener href="//help.rumble.com/">Developers</a>
					<a class="footer-nav-link" rel=noopener href="/team/">Our Team</a>
					<a class="footer-nav-link" rel=noopener href="/our-apps/">Our Apps</a>
					<a class="footer-nav-link" target=_blank rel=noopener href="//corp.rumble.com/">About Us</a>
				</nav>

				<div class="footer-terms-copyright">
					<nav class="footer-terms">
						<a class="footer-terms-link divider" rel="nofollow" href="/s/terms">Terms &amp; Conditions</a>
						<a class="footer-terms-link divider" rel="nofollow" href="/s/privacy">Privacy Policy</a>
						<a class="footer-terms-link" rel="nofollow" href="/s/dmca">Copyright / DMCA</a>
					</nav>
					<p class="footer-copyright">Copyright &copy; 2021 Rumble. All Rights Reserved.</p>
				</div>
			</div>
		</footer>
		<script>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</script><script src="//ap.lijit.com/www/sovrn_beacon_standalone/sovrn_standalone_beacon.js?iid=13427905" async="true"></script>		</body>
		</html>